WordPress 3.4 – Erreur fatale lors de la mise à niveau de votre base de données

(Source: Traduction de :http://www.techbeast.net/2012/06/13/wordpress-3-4-fatal-error-upgrading-database/)

WordPress 3.4 – Erreur fatale lors de la mise à niveau de votre base de données
Publié le 13 Juin 2012, par Gavin Lewis

 

Si vous avez mis à jour votre installation de WordPress à 3,4, vous pouvez avoir été accueillis avec un message d’erreur  plutôt effrayant:

Fatal error: Call to undefined méthode dbrc_wpdb :: delete () dans …. wp-includes/option.php à la ligne 370

 

Heureusement, le correctif devrait être assez simple. Si vous utilisez une variation du plugin cache DB, cela peut être la cause du problème.

Pour résoudre ce problème, vous aurez besoin d’ouvrir votre client FTP, accédez à wp-content et renommer db.php en old.db.php (ou autre pour qu’il ne soit plus pris en compte.)

Recharger la page avec le message d’erreur et il devrait dire « mise à jour complète ». (heureusement!)

A présent, vous devez vous rendre dans votre interface d’administration de wordpress dans Mise à jour vous devriez avoir la mise à jour proposé par DBCache.

Encore une fois, je ne prends pas la responsabilité de votre site si cela se passais mal. Tout ce que je peux dire, c’est que cela a fonctionné pour moi.

[message_box type="info" icon="yes" close="Hide"]Mise à jour:

Ivan, le créateur de la DB-Cache-Reloaded-Fix arrêté par la nuit dernière pour m’informer que son plugin a été mis à jour pour être compatible avec 3.4. Donc, il doit être sûr de le rajouter dans maintenant si vous l’avez supprimé.[/message_box]

 

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *